Seit 02.06. kein InfuxDB Export mehr?

Hallo,
ich hoffe ich bin hier richtig, wenn nicht bitte ich um Entschuldigung.

Ich habe seit gut 2 Jahren in meinem fems1482 zusätzlich einen influxDB-Datenexport konfiguriert, die lokale Influx-DB läuft auf einem Raspberry im Heimnetzwerk (der Support hatte mir das freundlicherweise konfiguriert).
Seit gestern 02.06.2022, ca 10:41 werden aus dem FEMS keine Daten mehr Richtung InfluxDB exportiert, ohne irgendwelche Interaktionen von mir. Weder am fems noch am raspberry…
Der Log liefert reihenweise folgende Fehler :
/======================
FrameworkEvent ERROR
3.6.2022, 14:25:34
ERROR
io.openems.edge.timedata.influxdb.InfluxTimedataImpl
bundle io.openems.edge.timedata.influxdb:1.0.0.202205231547 (143)[io.openems.edge.timedata.influxdb.InfluxTimedataImpl(52)] : The activate method has thrown an exception
3.6.2022, 14:25:34
INFO
io.openems.edge.common.component.AbstractOpenemsComponent
[influx0] Activate Timedata.InfluxDB
3.6.2022, 14:25:34
INFO
io.openems.edge.controller.debuglog.DebugLogImpl
[ctrlDebugLog0] _componentManager[Defective:influx0[Failed activation java.lang.NullPointerException: Cannot invoke “String.length()” because “this.input” is null]|State:INFO: OutOfMemory had happened. Found heap dump files.| FAULT: A configured OpenEMS Component was not activated] _sum[State:Fault Ess SoC:100 %|L:0 W Grid:-3280 W Production:3540 W Consumption:260 W] ess0[SoC:100 %|L:0 W|Allowed:0;8983 W] meter0[L:-3280 W] meter1[L:0 W] meter2[L:3540 W]
3.6.2022, 14:25:34
ERROR
Events.Framework
//===================

Im Anlagenprofile ist influx0 noch konfiguriert, allerdings ohne url …?
//===================
influx0

influx0 Timedata InfluxDB

apiKey:
bucket:
isReadOnly: false
noOfCycles: 60
org: -
url: 

//===================
Aktuelle Version auf dem FEMS ist [2022.5.5 (2022-05-23)]

Kann es sein, daß gestern OTA die version 2022.5.5 installiert wurde und die influxDB-Einstellungen gelöscht hat ?
Oder schlummert da ein Bug (siehe “OutOfMemory had happened. Found heap dump files” oben) ?

Für jede Hilfe bin ich dankbar.

PS : ich kann das nicht selbst korrigieren, einloggen via lokaler IP und admin geht nicht.

Hallo Tom-r,

willkommen in der OpenEMS Community. Tatsächlich sind Sie hier eigentlich falsch. Für FEMS bzw. Ihren FENECON Speicher erhalten Sie professionellen Service über die FENECON Servicehotline. OpenEMS ist die Open-Source-Software mit Unterstützung durch die Community.

Grund für den Ausfall der Übertragung dürfte tatsächlich das Update auf die neueste Version gewesen sein. Dabei war die Unterstützung für InfluxDB 2 enthalten, für die sich aber leider die Konfiguration geändert hat, die somit manuell angepasst werden musste. (siehe reworked Config and Influx to be compatible with InfluxDBv2 by simonfey · Pull Request #1769 · OpenEMS/openems · GitHub)

Ich habe bei Ihrem FEMS die Einstellungen aktualisiert, so dass jetzt wieder Daten ankommen sollten.

Gruß,
Stefan

Hallo Stefan,

funktioniert wieder, danke :slight_smile:
Ich gebe dem Service Bescheid, daß die nicht mehr aktiv werden müssen.
Viele Grüße,

Thomas

1 Like