Änderung der Tibber-API

In io.openems.edge.timeofusetariff.tibber/src/io/openems/edge/timeofusetariff/tibber/TibberImpl.java wird die alte API aufgerufen:

private static final String TIBBER_API_URL = "https://api.tibber.com/v1-beta/gql";

Previously, the connection could be established at wss://api.tibber.com/v1-beta/gql/subscriptions. After the change the URL must be queried via GraphQL (see example below) and client must support graphql-transport-ws sub-protocol.

Thanks @sputniki.

According to the docs you linked, the API endpoint we are using is still valid.

The ‘breaking change’ is only for subscribtions via WebSocket, which we are not using.

If I am not wrong, there is nothing we need to change at the moment.

Ok, I was looking for the reason why the Tibber-Controller is not able to fetch the current prices from the API.

Bildschirm­foto 2023-02-06 um 10.56.32

It’s working on my private OpenEMS setup… :slight_smile:


Do you have a log - or is it a FEMS?

It’s a FEMS :speak_no_evil: :sweat_smile:
May be a problem with more than one “houses” with Tibber?
Unfortunately I have only this screenshot:

Yes, the problem is with you having multiple ‘Homes’ in your API result. I provided a fix here:

(The “filter” option is not required to be set in your case, because only one Tibber result is actually valid, the other one is ‘null’)

1 Like

Thx! Works perfectly now :wink:
Bildschirm­foto 2023-02-09 um 13.35.49

1 Like