Error conencting to Wago Fieldbus Coupler 750 342 with Modbus TCP


I am trying to connect the Wago coupler to an instance of OpenEMS Edge. My OpenEMS Edge instance is running on 192.XX.XX.x and the IP of the Wago Coupler is 192.XX.XX.y.
I have done the following steps on the config Manager:

  1. Added a Bridge Modbus/TCP component with address 192.XX.XX.x
  2. Added a WAGO Fieldbus Coupler 750-352 component.

I get an error when it is trying to access and load the config file. I also tried changing the Bridge Modbus/TCP address to 192.XX.XX.y. The connect is refused while trying to download the ‘ea-config.xml’.

What other steps should I be taking and where should I add the address/IP of the Wago component?

Best Regards,

Hi dsen,

the WAGO Coupler needs to provide a configuration file (either ea-config.xml or io_config.xml) that OpenEMS Edge can read to identify the connected IO modules.

If I recall correctly, you have to login to the WAGO Coupler once and click a generate config.xml somewhere. Can you please try? - and post a screenshot if it works out? :slight_smile:


Hi stefan,

I did try to get the config from the Wago Coupler device. But there was no such option to generate the config. On going into the specifications, it seem the Wago device we are using a more primitive version than the implementation on OpenEMS.

Thank you for the advice
Warm regards,