Error When Integrating Simulator EVCS Component in OpenEMS Scenario

Hello OpenEMS Community,

I hope you’re all doing well. I’m reaching out because I’ve encountered a challenge in my OpenEMS scenario that I could use some assistance with.

Firstly, I want to mention that I’ve successfully developed a scenario involving PV and ESS components. I’ve thoroughly tested them with various controllers and conducted detailed analyses, and I’m pleased to report that everything seems to be working very well.

However, I recently introduced a Simulator EVCS component to my setup, and I’ve run into an issue that I’m struggling to resolve. Upon adding the Simulator EVCS, I noticed the following error log:

Copy code
bundle io.openems.edge.simulator: (153)[io.openems.edge.simulator.evcs.SimulatorEvcsImpl(78)] : Error during instantiation of the implementation object
8/18/2023, 4:37:32 PM
FrameworkEvent ERROR
8/18/2023, 4:37:32 PM
bundle io.openems.edge.simulator: (153)[io.openems.edge.simulator.evcs.SimulatorEvcsImpl(78)] : Error during instantiation of the implementation object
8/18/2023, 4:37:32 PM
[ctrlDebugLog0] _componentManager[Defective:evcs0[Failed activation java.lang.reflect.InvocationTargetException]|State:FAULT: A configured OpenEMS Component was not activated] _sum[State:Fault Ess SoC:66 %|L:0 W Grid:-5471 W Production:3584 W Consumption:-1887 W] ctrlBalancingSchedule0[State:INFO: No active Set-Point given] ess0[SoC:66 %|L:0 W|Allowed:-10000;10000 W] meter0[-5471 W] meter1[-1887 W] meter2[3584 W]
I’m unsure how to proceed with troubleshooting this issue, and I’m reaching out to the community for guidance. It’s possible that I may have misconfigured something or missed a crucial step in integrating the Simulator EVCS component.

If anyone has experienced a similar situation or has any insights into what might be causing this error, I would greatly appreciate your assistance. I’m open to any suggestions or recommendations to help me pinpoint and resolve the problem.

Thank you so much for your time and support. I look forward to your valuable input.

Best regards,
Razan Habeeb

I can see from the log message that the component evcs0 fails to activate. Take a look at its configuration and verify it it is correct.
To give you further advices, please post the configuration of the component.

Thank you so much for your response. I’ve been facing persistent difficulties with this issue, and I’ve attempted various troubleshooting steps, including testing with older versions and exploring other EVCS configurations like EVCS Keba. Unfortunately, the problem persists with Simulator EVCS.

I’ve used the default configuration settings for the Simulator EVCS component. The error log suggests that the activation of ‘evcs0’ is failing. I’ve reviewed the configuration, but I haven’t been able to identify any obvious issues.

To provide further context, I’m working with the SimulatorEvcsImpl class, and I suspect that the issue might lie within its instantiation or activation process. If you have any insights or guidance on how to troubleshoot and resolve this activation problem, I would greatly appreciate your assistance.

If you need any specific details, please let me know, and I’ll be more than happy to share them. Your expertise would be invaluable in helping me overcome this challenge.

Thank you again for your time and assistance.

You’re welcome. Is anything meaningful in the stacktrace of the exception?

Otherwise you could take a look at this topic 2023.8 Modbus Bridge CycleTimeIsTooShort which may relates to your issue.


Thank you for your response and suggestion.

I wanted to provide an update on the situation. Unfortunately, the suggestions and the related topic provided in the previous conversation didn’t resolve the issue with the Simulator EVCS component. I’ve thoroughly reviewed the configuration and checked the stack trace, but I’m still facing the same problem.

As an additional note, I did try using version 2022.10.0, and it worked without this specific issue. However, I encountered a different problem with another configuration.

I’m hoping that someone in the community might have encountered a similar situation or could offer further guidance to help me pinpoint and resolve this activation problem with the Simulator EVCS component.

Once again, I’m grateful for your time and assistance.

Best regards,
Razan Habeeb

Hi Razan,

I just checked it myselt. There is indeed an error in the implementation of the simulated Evcs: The channel ACTIVE_CONSUMPTION_ENERGY exists in both, ElectricityMeter.ChannelId and Evcs.ChannelId, so you have a duplicated ChannelId, and the constructor throws an exception.

I don’t know what the easiest solution to this is. Maybe, for the moment, you simply rename the channel in the Evcs-interface to EVCS_ACTIVE_CONSUMPTION_ENERGY or something? Or does someone else have a better and similarly short solution?

Best regards,

Not sure if it is a good idea to rename the Evcs.ACTIVE_CONSUMPTION_ENERGY. I would prefer removing the EletricityMeter interface from the Simulated EVCS. Else it may confuse the OpenEMS UI. Because within OpenEMS UI the EVCS may sometimes be handled as EVCS and somtimes as meter.
Also I see no reason, why a simulated EVCS should be an ElectricityMeter.

Hi again,

Unfortunately, none of the previous solutions worked for me.

I recently encountered some issues with the OpenEMS UI after downgrading to version 2022.10.0. While my EVCS (Electric Vehicle Charging Station) component is working fine, I’m facing challenges with configuring channels and retrieving data in the historical tab.

Here’s the problem I’m experiencing:

Channel Configuration: I’ve set up channels to retrieve data from InfluxDB. I’ve verified that data is being written to InfluxDB and that the configuration for the time data in InfluxDB is correct. However, when I attempt to save the channels I’ve configured, the changes do not get saved.

Historical Data: Even after configuring channels, I’m unable to retrieve any data in the historical tab. The data appears to be missing or not being displayed.

I didn’t encounter these issues in the latest version of OpenEMS, so I’m wondering if there are any specific considerations or known changes in version 2022.10.0 that might be causing these problems

Hi Razan,

Good to read that your EVCS is working now.
The problem with the historical tab not showing any data might be that there was a major change in the natures of OpenEMS since October. The old natures SymmetricMeter and AsymmetricMeter were replaced by the new nature ElectricityMeter, which the old UI won’t know.

Best regards,

Thanks, Thomas, for your prompt reply. So, in this case, is there any alternative solution to display my results in a historical diagram?

Hi Sn0w3y,

Sorry, I couldn’t get your point here.

BTW: Try Updating the UI :slight_smile:

Hi, Thanks for answering, I’ve been using Simulator Components on my computer for testing, and I believe I’m utilizing the Edge to display my data.

I’ve tried to visualize my data using Grafana but I encountered an issue. It seems that there’s no “EVCS” field available, but when I checked InfluxDB, it showed me “meter1” and “meter2” instead. I don’t have these in my simulation, and I’m not sure if they relate to symmetric and asymmetric meters.

Furthermore, while I can access information in EVCS channels from OpenEMS, it’s not being saved, so the history tab isn’t working.

You said that updating the UI might help, but I’m uncertain about the preferable way to do this. Also, I’m concerned that updating might not recognize the old EVCS configurations.

Actually there is no other way. As openEMS had a Breaking Change in the Code where the Meters have been refactored.

If you want to use the newest Version of openEMS you need the newest Version of the UI.

Do you have activated the RRD4J Module on the Edge Device?

If yes, what is shown in the UI under the History Tab? Maybe provide a Screenshot! :slight_smile:


If could notice from the beginning I tried the latest version but the simulator EVCS wasn’t working. This is why I went back to an old version.

I activated the RRD4J Module on the edge Device and the graph is displayed

1 Like