[FEMS] FENECON Relaisboard

Hallo,

wurde hier an das Board verwiesen. Aktuelles Problem: ( eigentlich schon seit einem Jahr) Habe ein Relaisboard das eine Wärmepumpe mittels SG Ready ansteuert sobald Überschuss vorhanden ist (Wärmepumpen APP FENECON). Leider steuert dieses Board die WP auch an wenn kein Überschuss vorhanden ist. Auch Nachts! Durch Stromabrechnung ist der Fehler aufgefallen. Nach einem Jahr doppelte Stromrechnung (WP ohne Fenecon APP: 4000 kwh, mit Fenecon APP 8000kwh Strom pro Jahr) Durch abklemmen des Relaisboard funktioniert die WP wieder einwandfrei.

Anbei noch ein Diagramm vom WP Hersteller, der das fehlerhafte Verhalten dokumentiert. Das gelbe Signal gibt an wann der potentialfreie Kontakt der WP geschlossen wurde. Also quasi wann das Relaisboard geschaltet hat.

Auch noch die Erweiterungsplatine als PDF der WP.
Keiner will/kann mir in dieser Angelegenheit helfen. Vielleicht kann hier jemand helfen. Würde einfach gerne den Eigenverbrauch erhöhen und nicht den Strombezug verdoppeln.
MA_WP_Erweiterungsplatine_MDSK_Typ2-1.pdf (2.8 MB)

Moin @jone-VB ,

Ich habe meine schmerzhaften Experimente mit SGready bereits hinter mir. Damals lies ich dies ebenfalls per Relais steuern, wenn PV-Überschuss bestand. Hat funktioniert wie ein Sack Nüsse und mir die WP, bzw. die E-Heizungs-Steuerung, kaputt gemacht.
Wie bei Dir zu sehen, taktet die WP auch fröhlich vor sich hin. Das mögen Kompressor-geführte Geräte gar nicht.
Wenn Du Zeit und Lust hast, kannst Du Dir ja meine Odyssee ja mal auf meiner Homepage anschauen.

Die Schaltzeiten des Relais in der Nacht verstehe ich nicht wirklich. Was sagt denn die OpenEMS History? Die Schaltzeiten müssten dort doch auch zu finden sein. Es sieht ja fast so aus, als sei die Schaltung negiert: Bei Überschuss keine WP…
Seltsam…

Die Schaltzeiten in der Software korrelieren nicht mit den tatsächlichen Hardware Schaltzeiten. Schaut man sich rein die Software an sieht es aus als würde alles „funktionieren“. Mit einem Hardware Logger allerdings kann ich sehen, dass die Signale die von der Relaiskarte ausgehen auch richtig von der WP erkannt werden und genauso anliegen wie im Diagramm oben dargestellt. Also die Fehler durch die Relaiskarte produziert werden und zwar auch reproduzierbar. Entweder ist die Relaiskarte defekt oder durch irgendwelche Störsignale werden hardwareseitig die Relais angesteuert. Da in der App alles normal aussieht sagen die „Softi‘s“ dass kein Problem zu erkennen ist… ziemlich schwierige Situation.

Ich behaupte jetzt mal, dass die Relays vertauscht sind. Einschaltempfehlung - Sperre - Einschaltbefehl

Das kann ich mir nicht anders erklären. Tausch doch bitte mal die 4 Drähte.

Wurde bereits ein Update auf das Relaisboard aufgespielt ?

Ist es ein Fenecon Home oder ein GoodWe GW10K-ET mit BYD System?

Ok danke. Es werden sowieso nur zwei Drähte benutzt. Die Wärmepumpe hat nur einen Eingang wenn dieser geschlossen ist wird eingeschaltet. Wie soll ich die Drähte tauschen? Es ist Relais 5 als Einschaltbefehl konfiguriert. An Relais 5 hängt auch das Kabel. Es ist als NO verdrahtet. Wie gesagt es wird das Relais angesteuert (led an) in der Software wird der Ausgang aber als inaktiv angezeigt.

Wie kann ich ein update der Relaiskarte machen?

Es ist kein Home sondern ein Goodwe GW10k ET mit BYD.

Dann hast du KEINE SG-Ready Schnittstelle, sondern einen PV-Kontakt. Dieser ist NICHT für SG-Ready “tauglich”, da der diese 4 Schaltzustände:

  1. Sperre
  2. Einschaltbefehl
  3. Einschaltempfehlung
  4. Normalbetrieb

defakto nicht hat.

Die FEMS-App ist NUR für SG-Ready ausgelegt und dementsprechend erwartet die FEMS auch 4 Schaltzustände an der Wärmepumpe und nicht nur einen.

Wo siehst du das?

Da wäre ein LOG-Output sehr hilfreich aus dem FEMS.

Beim GoodWe System gar nicht und du schonmal auch gar nicht :smiley:
Wenn dann FENECON aber nicht beim GoodWe

Ich arbeite nicht bei Fenecon, diese Aussagen basieren aber alle auf Erfahrungen mit OpenEMS :wink:

Meiner Mienung nach wäre die FEMS-App Schwellwertsteuerung für diesen Anwendungsfall besser. Da erwartet die FEMS eben auch nur einen Ausgang, der geschalten wird.

Hast du die Leistung deiner WP auch richtig eingetragen?

Grüße !

Ja danke, das ist mir bewusst. Meine WP kann nicht zwischen Betriebszustand 3 und 4 unterscheiden was aber nichts macht da ich ja auch die Schwellwerte für die einschaltempfehlung und für den einschaltbefehl in der App konfigurieren kann. Ich könnte sogar die beiden NO Kontakte des Relais in Reihe schalten um nur den 1:1 Befehl zu bekommen.
Es erklärt aber nicht warum das Relais auch nachts schaltet. Das Relais für die betriebsart X:1 darf eigentlich nur schalten wenn ich einen Überschuss habe. Oder sehe ich das falsch? Es sind ja nur Ausgänge die keine Rückmeldung haben.

Den „angeblichen“ Zustand des Relais sehe ich in der App. Da stehen oben zwei Zeilen - in der einen Zeile steht Zustand. In der zweiten steht Modus. Mit dem Anzeigewert „Zustand“ habe ich immer verglichen wenn das Relais an oder aus war. Was ja auch grob stimmt. Bloß sporadisch wird halt das Relais auch noch geschaltet.

Es sind doch alle Wechselrichter von Goodwe? Egal ob es das alte oder neue System ist. Es kann höchstens sein das auf den neuen Dingern eine Custom Firmware läuft… für mich aber auch kein Unterschied für die Relaiskarte. Die würde ja ohnehin nicht per Wechselrichter aktualisiert werden. Denke einfach das es Firmenpolitische Gründe sind. Die „alten“ Systeme werden meiner Meinung sehr stiefmütterlich behandelt…

Die FEMS möchte aber trotzdem 4 Schaltzustände schalten. Du hast nur EINEN…

Die App SG-Ready ist defakto überhaupt nicht ausgelegt für so einen Fall. Wie gesagt. du brauchst die App “Schwellwertsteuerung”.

Grüße

Die FEMS möchte aber trotzdem 4 Schaltzustände schalten. Du hast nur EINEN…

Stimmt nicht. Man kann - wie jone-VB auch schreibt - in der App die Betriebszustände:

  • Einschaltempfehlung
  • Einschaltbefehl
  • Sperre

jeweils an- oder abwählen. Wenn bspw. nur ein Wechsel von Normalbetrieb und Einschaltempfehlung stattfinden soll, reicht es, wenn man die zwei anderen Betriebszustände abwählt.
Wenn man Einschaltbefehl statt Einschaltempfehlung verwendet, “gewinnt” man die zusätzliche Möglichkeit, den SoC als Parameter zu verwenden.

Nutze ich selber so und funktioniert einwandfrei.

Dann hast du KEINE SG-Ready Schnittstelle, sondern einen PV-Kontakt. Dieser ist NICHT für SG-Ready “tauglich”, da der diese 4 Schaltzustände […] defakto nicht hat.

Stimmt auch nicht. Der bwp unterscheidet bei den “Anforderungen für das SG Ready Label” für Wärmepumpen explizit zwischen:

  • Heizungswärmepumpen und
  • Warmwasserwärmepumpen

Für Warmwasserwärmepumpen gilt:

“Warmwasserwärmepumpen müssen über einen Regler verfügen, welches mittels einer automatischen Ansteuerung eine Erhöhung der Warmwasser-Solltemperatur zum Zweck der thermischen Speicherung ermöglicht.”
Quelle: https://www.waermepumpe.de/normen-technik/sg-ready/

Warmwasserwärmepumpen dürfen also durchaus das Siegel “SG-ready” tragen, wenn sie über einen Eingangskontakt zur Erhöhung der Warmwasser-Solltemperatur verfügen.

Grüße

Flo

Na gut Flo,

dann sag Ihm doch, wieso es bei Ihm nicht funktioniert ? :slight_smile:

Grüße

Vielen Dank Flo für deine Expertise.
Ich habe bei der Installation des Relaisboards damals auch alles genau so eingestellt wie du es beschrieben hast. Wenn es bei dir funktioniert dann kann es eigentlich nur ein Hardware Fehler im Relaisboard sein. Du hast mir sehr weitergeholfen und meine These bestätigt. Danke! Weiß nun wie ich weitermachen kann.

Dachte mittlerweile ich verstehe gar nichts mehr - wie selbstbewusst manche einfach immer Behauptungen raus hauen…