Issue with Modifying Balancing Schedule in OpenEMS - No Reflection in UI

Hello OpenEMS Community,

I am facing an issue with modifying the balancing schedule in OpenEMS, and I’m seeking assistance in resolving it.

Problem Description:
I have set the balancing schedule parameter with the following values:

[ { “startTimestamp”: 1577836800, “duration”: 900, “activePowerSetPoint”: 0 }, { “startTimestamp”: 1577837700, “duration”: 900, “activePowerSetPoint”: -2000 }]

However, after saving the changes, I do not see any reflection of the modified schedule in the OpenEMS user interface.

Steps to Reproduce:

Access the OpenEMS UI.
Navigate to the “Balancing Schedule” section.
Modify the schedule parameter with the provided values.
Save the changes.
Expected Outcome:
I expect to see the modified balancing schedule reflected in the OpenEMS user interface.

What I’ve Tried:

I have cleared my browser cache and refreshed the page, but the changes are still not visible.
I tried to set the value by REST API, but without any result.
Additional Information:

When I tried to change the SOC of “ESSSymmetric Reacting” to 60%, the changes were immediately visible.

[ctrlBackend0] Duplicate Key [“”]
2023-07-25T13:37:44,906 [_cycle ] INFO [ebuglog.ControllerDebugLogImpl] [ctrlDebugLog0] _sum[State:Fault Ess SoC:60 %|L:0 W Grid:1156 W Consumption:1156 W] ctrlApiRest0[State:FAULT: Unable to start REST-Api Server] ctrlBalancingSchedule0[State:INFO: No active Set-Point given] ess0[SoC:60 %|L:0 W|On-Grid] meter0[1156 W]

Any guidance or insights into why the changes are not reflected in the UI would be greatly appreciated. I am open to any suggestions or troubleshooting steps to resolve this issue.

Thank you for your time and assistance.

Best regards,
Razan Habeeb

Hi Razan & welcome to the OpenEMS Community!

Your configuration sounds ok, but I have to admit I did not use the Balancing Schedule Controller for a while. You are referring to the docs here, right? Controller :: Open Energy Management System

After you applied the changes - either via OpenEMS UI or via Apache Felix Web Console - you should be able to see the configured schedule also in the actual persisted config file in C:\openems\config\Controller\...

Do you have any content there?

Also the log [ctrlBackend0] Duplicate Key [“”] looks a little bit fishy… there might be a misconfiguration somewhere.


Hi Stefan,

I have set up InfluxDB and OpenEMS. The InfluxDB server is running and accessible as confirmed by a successful curl test. I’ve configured the “Timedata InfluxDB” component in OpenEMS with the correct URL, Org, and Bucket. However, when I navigate to the Historical tab in the OpenEMS UI, it just keeps loading and doesn’t display any data. I’ve also noticed that when I configure the backend for InfluxDB in OpenEMS, the Historical tab stops loading altogether. Are there any additional configurations or troubleshooting steps I should take to ensure that historical data is displayed correctly in the OpenEMS UI? Any help or guidance would be greatly appreciated. Thank you!