OpenEMS with Odoo authentication failed


I am trying to setup openEMS together with Odoo following the gitpod examples, however in the backend I keep getting the error Connection to backend failed. Apikey [....]. Error: Unable to authenticate this Apikey.. I tried creating an edge in Odoo and setting this apiKey there but that doesn’t seem to help.

Any idea what I am doing wrong?

Thank you in advance!

Hi Sven,

and welcome to the OpenEMS community.

What you did sounds correct in principle. The error you see was thrown here:

With a Odoo Metadata provider, the error would originate from here:

In the current implementation the Edges are cached by OpenEMS Backend on initialization. This will be changed in future. Did you add the Edge in Odoo after starting the OpenEMS Backend? Can you try debugging the initialization (from openems/ at develop · OpenEMS/openems · GitHub) to see if the Edges are properly imported in Backend?


Yes I tried that but to no avail. Also seeing a lot of org.postgresql.util.PSQLException: ERROR: column “state” does not exist error from the backend, maybe that indicates another issue down the line?

Yes, this is the same problem I found also when I checked our Gitpod Live Demo recently:

I am sorry to say, that the Odoo module seems to be broken right now. We use it in production internally on Odoo v14, and need to find time to backport it to Community (which is difficult right now because we have so many Corona cases…)


I gave the Gitpod Live-Demo a complete overhaul. Live-Demo should now work with this link: (this runs the develop branch demo, because the required updates will only be released to master on 1st of June)

Updated documentation for Gitpod Live-Demo is here: