Problem Getting Started; Errors in Import/build of workspace in eclipse


I have followed the Getting Started guide and am stuck at step 2.3 for many days. I have tried almost all the solutions provided in other, related threads… like clean, then rebuild, refresh etc. Also, have tried many versions of eclipse including 2020-06. I have also tried java versions – 8, and 16. Nothing solved the problem for me. If someone could help me get out of this exhausting situation.

Attached herewith is the screenshot of problems I have encountered:


I can unfortunately only guess what the problem could be. The error messages all point to missing Classes from external libraries, which sounds like there is something wrong with how Bndtools downloads and provides the libaries defined in the Maven pom.xml file.

  1. Check that you are actually in the ‘Bndtools’ Perspective
  2. Open the /cnf/build.bnd file and click the Reload button on bottom right. It should trigger re-downloading the dependencies

(Builds are working fine with me on Eclipse 2021-09 with Bndtools 5.3)


1 Like

Thanks for the response Stefan.

  1. Yes I am in bndTools perspective.
  2. Unfortunately this did not work for me.

What I have done is, I have tried to get the errors removed one by one. I added the missing .jar files in /cnf/local externally and got each error removed. Now I am left with 8 errors because till now I am unable to get an “org.eclipse.jetty.util” jar which works with the project.

Do you have any idea why these sort of bnd errors usually occur? I have almost dealt with these this time, but I have to implement it on a different machine also. I am afraid.

Have you tried building the project outside of Eclipse in the console using ./gradlew build?

This is what we run in our Github Actions (openems/build.yml at develop · OpenEMS/openems · GitHub) and our Gitpod Live-Demo (openems/.gitpod.yml at develop · OpenEMS/openems · GitHub)

1 Like


Thanks a lot Stefan for your time and kind help.

The problem I was getting in import of the projects in eclipse was because of unresolved dependencies. The problem has been resolved. This how it was done:

  1. Take each error one by one.
  2. search for the missing file( e.g: “org.apache.felix.http” ) in the repositories search bar.
  3. Usually it will appear under “Maven Central” category. If it does then:
  • Go to → C:\users\usr.m2
  • Search for that missing file here and the folder containing it.
  • Refresh the repositories, then clean and rebuild projects. The error should go away taking many with it also.
  1. Continue doing this for other errors.


P.S: Also, I did not see anything at the UI for first. Then I according to updated GitHub UI documentation, I changed the port from 8085 to 8075. It worked well then.