Problem in Run OpenEMS Edge and Start Simulator


I am using OpenEMS for a project which involves control of a microgrid with rooftop PV system, Battery Storage, Utility Import/Export and Electric-Only Load.

I am interested in the development of OpenEMS and want to customize/improve it for my project.

I have cloned the OpenEMS repository and the supporting tools (Sourcetree, Java SE Development Kit 8, ECLIPSE for Java, Bndtools).

I have followed all the guidelines as per Getting Started page of OpenEMS guide but have observed a problem in step where I want to “Run OpenEMS Edge and Start Simulator”.

The problem is that after building through Bndtools I am getting these warnings (which are not expected) --> Picture1

And when I open the project [io.openems.edge.application] and double click on [EdgeApp.bndrun] and click on [Run OSGi] to run [OpenEMS Edge] I get following Error -->Picture2

I am not sure what this error means and how to avoid this since I have followed all the guidelines of OpeEMS development environment.

I am using Windows 10 64-bit operating system.

Can you please look into this and guide me in resolving this issue?

Thank you.

Best Regards!


After installing the git application, the warnings are gone so the build is without any problem.

But when I click on the running the OSGi for [io.openems.edge.application] the same error appears (Error: Could not find or load main class Mansoor\git\openems\io.openems.edge.application\generated\

Somehow there is some class file which is not letting run the application.

What do you think?

Best Regards,


It’s really hard to say what the problem is. Can you try to reset your cloned directory, create a new Eclipse Workspace and import from scratch.

If all that fails; I believe I need to have a look myself using Windows Remote Support or similar.


Hi Stefan,

Thanks for your reply.

I have tried resetting the clone directory, creating new eclipse workspace and import from scratch but still getting the problem.

It would be great if you can help using remote support.


Best Regards,
Muhammad Mansoor

Thanks Stefan for your valuable time and remote help.

I created another user without spaces and the error is resolved.
It seems that spaces in user names are creating some problems in running the bnd components.

Best Regards,
Muhammad Mansoor

1 Like

Hi, I have the same issue.

I followed the steps on:
I’m on Windows 10 (64 bit) using GitHub Desktop.
Please advise.
Many thanks!

Hi Harm,

it looks to me, that you have some problems with your git installation. Please check if your git is installed properly and that it is reachable from windows command line. To do so you can press <win>-r and type “cmd” in the input field and start it. Then type “git”. You should now see the git command line help output. If you got back an error here, your git is not installed properly.
Either GitHub Desktop does not provide a git command line utility or it is not added to your system path correctly. I do not know GitHub Desktop. I am using Git and TortoiseGit for Windows. After installing them and rebooting the system I can use git from the command line.

Hope that helps,

1 Like

Thanks Christian,

I dropped that requirement from the build.bnd file - we did not use it anyways:

@Harm: Problem should disappear if you pull the latest develop version


Thanks Stefan and Christian,
That solved the issue :+1:
(I am a developer, but quite new to Java Eclipse and git. Hope to learn fast :wink: )

Good to know it’s working now.

Make sure to get back here if you run into problems. Do you have any concrete plans already on how to use OpenEMS?