Change port for web console

Hello Everybody,

I have a problem with getting access to the apache felix web console. The default port: 8080 is already in use on my computer so I want so change the used port in openEMS.
But I don´t know where to change the port.

What I tried is the following:

I changed the port in the EdgeApp Source document (to 8888)
It seems to have worked. The console output I get is the following:

org.apache.felix.http.jetty [org.eclipse.jetty.server.AbstractConnector] INFO : Started ServerConnector@5d47f08d{HTTP/1.1, (http/1.1)}{}
2021-11-10 15:11:45,715 [artLevel] INFO [org.apache.felix.http.jetty ] Started Jetty 9.4.43.v20210629 at port(s) HTTP:8888 on context path / [minThreads=8,maxThreads=200,acceptors=2,selectors=10]
2021-11-10 15:11:45,773 [artLevel] WARN [ntmanager.ComponentManagerImpl] bundle io.openems.edge.core: (75)[io.openems.edge.core.componentmanager.ComponentManagerImpl(1)] : Could not get service from ref [io.openems.edge.common.component.ComponentManager, io.openems.edge.common.component.OpenemsComponent, io.openems.edge.common.jsonapi.JsonApi,]
2021-11-10 15:11:45,774 [artLevel] ERROR [ROOT ] bundle org.apache.felix.scr:2.1.30 (162) Circular reference detected trying to get service [io.openems.edge.predictor.api.manager.PredictorManager, io.openems.edge.common.component.OpenemsComponent, io.openems.edge.common.jsonapi.JsonApi]
stack of references: ServiceReference: [io.openems.edge.predictor.api.manager.PredictorManager, io.openems.edge.common.component.OpenemsComponent, io.openems.edge.common.jsonapi.JsonApi]
ServiceReference: [io.openems.edge.common.component.ComponentManager, io.openems.edge.common.component.OpenemsComponent, io.openems.edge.common.jsonapi.JsonApi,]

But I still got an error when trying to open the web console in the browser: HTTP ERROR 404 Not Found

Do I have to change the port somewhere else or is it possible that I have a different porblem?

I am gratefull for any advise.

Best Regards


Hi Tobi,

that’s the same like i did, i even guess you can set is with a parameter, but i didn’t find it fast enough.
than you should reach it with http://localhost:8888/system/console/configMgr

and 404 means, that someone is “listening” :smiley: elsewise you would get n timeout.

best regards

Hi Paul,

Thank you for your fast response. You are right and my problem wasn´t that the port change didin´t work. I had a different problem that I fixed now.

best regards