Getting started problems simulation

Hello everyone,

I am new to the OpenEMS software and not a java developer by origin.
Interested in the OpenEMS software I have tried to install it using the getting started.

Unfortunately I am getting a lot of erros as soon as I import the git project into Eclipse.
Could anyone help me resolve these errors?

Kind regards,
Frank

Hi Frank,

thanks for getting in touch and sorry for the trouble. I have never seen these specific error messages and could not find immediate help in a quick google search. Usually those initial build errors can be solved by following the steps listed here - but I doubt it will help in this case.

If you just want to have a first look at what you can expect from OpenEMS Edge + Backend + UI, we just added support for Gitpod, which builds an entire demo of all components in your browser and lets you play with it. For now you can use this link to try the ‘develop’ branch:

(Support for Gitpod with master branch is going to come with the latest release later today.)

Regards,
Stefan

Thank you for your reply Stefan.
I will try some of the solutions you have provided.
Some other thing I noticed is that when I try to follow the steps as listed in the getting started.
The import step through Bndtools -> existing bnd workspace, does not work in my eclipse. It is there and I can select it but as soon as a click next nothing happens.

When installing Eclipse I have selected the first option which installs the Java dev kit, is this the right option since I noticed there is a second java dev option.

Which Eclipse version do you use?
I had problems with the latest version 2020-09 . The import of Bnd Workspace didn’t work anymore.
When I switched back to version 2020-06 this problem was solved.